Ad Radar
Item Posts    Sort Order

1987 Corvette Won't Start after New Engine Install

 
waynep71222
My first time was in a Chevy
Posts: 241
Joined: 04/12
Posted: 05/07/12 05:06 PM

on the deville... if its an early 90s model with the 4.5. or 4.9 motor.. not the north star versions..

check the vacuum hoses first..   the check valve has 2 outlets on the dash side..  one to the reserve tank.. the other to the dash board.. but just before the check valve..  there is a tee and hose down to the diverter valve on the smog pump.. those leak of get pulled off and the whole nine yards stops working do to lack of vacuum to operate the actuators..\

corvettes have the same problem..  leaky vacuum hoses..  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 05/07/12 06:00 PM

good to know

This is a 2002 with a northstar  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 05/07/12 06:59 PM

Just watched the stft ltft training video.  Excellent training session.  It is a great refresher!

Keep em coming.  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 05/08/12 09:30 PM

What does it mean if the idle air count is 70?  Hypothetically speaking.  

Post Reply
waynep71222
My first time was in a Chevy
Posts: 241
Joined: 04/12
Posted: 05/08/12 10:11 PM

if the IAC counts are at 70.. it shows the computer is trying to raise the idle speed ...

what are the other numbers...

actual idle numbers
desired idle numbers

engine coolant temp.  

TPS.  voltage???  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 05/08/12 10:16 PM

Oh, and I didn't forget.  I will check that MAF sensor as explained.  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 05/08/12 10:18 PM

How do I test the MAF sensor if it is not throwing a code?  

Post Reply
waynep71222
My first time was in a Chevy
Posts: 241
Joined: 04/12
Posted: 05/09/12 05:36 AM

since you have a service manual..

run DTC test charts for   code 33... high maf reading at idle...

code 36 burn off problem..

and probably
code 34 low MAF reading...



i know i have those files.. but i cannot find them..

at idle.. it should read on the scan tool.. like 6 grams per second...

say...   this is where we started... can you do a voltage drop test between the relay ground connections and the engine block..

or ADD a ground connection with a scotch tap terminal.. as its easily removed with only minor damage to the insulation ....

the maf power and the maf burn off relays cycling might have damaged the MAF sensor..



print out the charts...  33,   34  36.. run through each one...


86 165V8tpi 4  

Post Reply
waynep71222
My first time was in a Chevy
Posts: 241
Joined: 04/12
Posted: 05/13/12 12:10 AM

the scan tool data for an 87 L98 other TPI motors.   one warning.. TPS voltage has to be 0.52 volts + or - 0.08 volts for this system to work properly..

TPISCANDATA87  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 05/13/12 07:24 PM

Thanks again Wayne.  You are teaching me a lot and forcing me back into the shop manuals (good thing). I will be back onto the Vette later this week.  Still playing catch up from last week.  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 05/13/12 07:31 PM

Also, off topic, I was called by my neighbor to fix a broken well pipe (six feet under ground).  I am the guy the neighbors call when they need help with anything.  I don't mind and it makes me feel good to help, but I also get a bit overwhelmed sometimes.  I can't wait to get back onto the diagnosis of the car.  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 06/01/12 01:47 AM

I hope to get back on this soon.  I've been swamped.  Plugs and filter on a 2006 SRX, front drive pump on a Bobcat 743 and septic drain field installation.....  

Post Reply
87corvette
My first time was in a Chevy
Posts: 171
Joined: 03/12
Posted: 06/07/12 06:28 PM

Finally getting back on the vette.  Getting code 33 and 36 now.  This is making sense as this is the burn off rely and the MAP sensor.  I understand the burn off relay but not sure why MAP is being thrown.  

Post Reply
waynep71222
My first time was in a Chevy
Posts: 241
Joined: 04/12
Posted: 06/07/12 06:47 PM

back to where we started...  did you find the ground connection point for the maf relay and the burn off relay....

86 165V8tpi 4  

Post Reply
waynep71222
My first time was in a Chevy
Posts: 241
Joined: 04/12
Posted: 06/07/12 06:48 PM

i can SEE 4 different GROUND connections to the ECM in the image directly above...

each of these needs to be voltage drop tested... with the engine running.. between the back of the connector or the wire via a piercing terminal at the ecm connector.. to the ENGINE block..

on these 3 grounds... i see 3 separate ring terminals connected to the engine...

i know that there is a ground connection on the side of the block above the oil filter area..

there are also ring terminals that are probably bolted to the back of the heads.. about a 90% chance of that.. i don't have the 87 or 89 L98 ground connection locations diagrams...

from the fuel pump relay... pin A black and white to a ring terminal and ECM Pin A12

from the maf sensor power relay pin B black and white to a ring terminal ground and ECM pin D3

from the maf sensor  PIN A black and white to a ground ring terminal and ECM pin D1

from the maf sensor PIN B black and ECM pin A11

this is where i would start...
 

Post Reply
TO TOP