Ad Radar
Item Posts    Sort Order

97 chevy truck hard cold start

 
triggr_4
I love my Chevy Chevette!
Posts: 3
Joined: 02/09
Posted: 02/05/09 10:04 AM

i have a 97 chevy truck with a 5.3l vortec. this truck will barely start when its cold. recently changed the fuel pump, fuel filter, plugs and wires, cap and rotor. still no luck. any help???  

Post Reply
55Guy
V-6 Camaros rule!
Posts: 25
Joined: 05/07
Posted: 02/06/09 07:26 AM

Uh, if you've got a '97, unless you've swapped in a later model motor, that engine is NOT a 5.3L motor, it's a 5.7L Gen I Vortec motor.

Regardless, hard cold starting could be either a mass air flow sensor, or you could have a bad O2 sensor. Both of these are temp dependant and use temperature in their operation.  

Post Reply
triggr_4
I love my Chevy Chevette!
Posts: 3
Joined: 02/09
Posted: 02/07/09 07:20 AM

thanks for the heads up, but doesnt one of these throw a trouble code if there going bad? either way getting them checked out is better than havin it not start at all. thanks again  

Post Reply
55Guy
V-6 Camaros rule!
Posts: 25
Joined: 05/07
Posted: 02/09/09 12:25 PM

They should throw a check engine light, but sometimes they don't.

Now, one other thing I thought of, you said you changed the fuel pump. Did you take a look inside the gas tank to check for any trash or debris floating in the tank? When you pulled the old pump out, was there any crud on the filter sock?  

Post Reply
triggr_4
I love my Chevy Chevette!
Posts: 3
Joined: 02/09
Posted: 02/11/09 08:48 AM

afte i changed the pump and new sock the truck started fine for a year or so then it just started hard when its cold . once it starts it runs fine no sputtering or anything.  but after it sits for a couple of hours its the same old story.  sometimes i give it lil shot of carb cleaner and it fires right up on half a crank of the motor??? and then is fine like i said til it sits for a couple of hours.  

Post Reply
chevycrazy4
I love my Chevy Chevette!
Posts: 1
Joined: 03/09
Posted: 03/08/09 09:51 PM

have you found the prom my have the same thing change every and still the same.just when it sit once it start i does not do it the rest of the day to the next day  

Post Reply
geojudy
I love my Chevy Chevette!
Posts: 2
Joined: 04/09
Posted: 04/16/09 06:48 PM

have a 96 5.7 vortec same problem has a new t.p.s. fuel pressure regulator and cap, rotor and wires put on a batteriey charger helps some any ideas?  

Post Reply
lee188
I love my Chevy Chevette!
Posts: 2
Joined: 04/09
Posted: 04/21/09 08:30 PM

sure sounds like a fuel pump in both cases . they can last less than a year they spin very fast to produce 60 psi and on a battery charger higher voltage to fuel pump at start up is easier to provide fuel pressure put a fuel gauge on the schrader valve on the fuel line input on back of intake and watch for the pressure to bleed down after it build s pressure and watch for a long build up after sitting .hopefully this helps  very common 96-99 problem  

Post Reply
geojudy
I love my Chevy Chevette!
Posts: 2
Joined: 04/09
Posted: 04/29/09 03:11 PM

Changed fuel pump, fuel pump sock and wireing harness pigtail truck starts and runs like new thanks for evrybodys input  

Post Reply
Philip24hoyt
I love my Chevy Chevette!
Posts: 1
Joined: 01/12
Posted: 01/13/12 08:03 PM

I have a 96 chevy 2500. it starts fine when its warm but if it sits for a while when its cold outside then it wont. sometimes it will if i turn the key and let the fuel pump run and i repeat this 2 or three times. At times it will start by just barely cranking over but if i hold the key then it will just keep cranking and not start. Right now its frigid temperatures and snowing in ohio and i went out to start my truck and havent been able to start it all day long  

Post Reply
TO TOP