Item Posts    Sort Order

1992 Corvette electronic A/C module

 
Bruce1957
I love my Chevy Chevette!
Posts: 1
Joined: 10/11
Posted: 10/24/11 06:14 AM

Hi, I have a 1992 Vette and the electronic A/C module doesn't do anything. The display light illuminates when the key is on, but the screen is blank. No defrost or anything. The previous owner said there was a bad ground somewhere, but all the grounds check and there is power from the  when the key is on. . I bought a used Module on E-Bay, but doesn't work either. I got a Service Manual and started their troubleshooting procedure, but I haven't found anything. The orange wire is supposed to be from the courtesy fuse and hot but it isn't. I jumpered it but still no change. The display light shouldn't work with no power from the courtesy, so mabey I am reading something wrong. The manual doesn't give me proper locations on the points it wants me to check. Anyway, is this a common problm with an easy fix ?? You experienced Corvette guys probbly seen this before.(I hope). HELP !!

Bruce Confused  

Post Reply
waynep7122
I mow my lawn and find Chevys
Posts: 1114
Joined: 08/09
Posted: 10/24/11 08:05 AM

if you don't get other responses.. this will take me a day or two to find a wiring diagram for the AC system..  most of my printed info is drivability..

since you have a manual.. follow the fuse power side supply...  probably from a fusible link...

use extreme care when jumping items...  you could let the smoke out..

i might have something for you late tonight or tomorrow morning.. if there are no other posts..


just a quick edit up date.. late monday night..

i still have not found the HVAC wiring diagram i need to help you...   i might get to a friends shop tomorrow who might have it..  

Post Reply
waynep7122
I mow my lawn and find Chevys
Posts: 1114
Joined: 08/09
Posted: 10/26/11 04:10 PM

i finally got by my friends shop...

he was busy... and only printed me out one page of the several that i really needed...

you should have 2 power sources into the programmer..

Constant battery power..
Courtesy lamp fuse 15 Amp is an ORANGE wire into heater and AC programmer PIN C4,  

   
Switched power
A/C fuse   15 Amp   is a Brown wire into heater and AC programmer PIN D1 and also to the heater and AC control head PIN 1…

heater and AC programmer ground wiring is on PIN  C12 and goes to splice S203 and then to  ground point  G201


so on the Heater and AC programmer...

PIN C4 Orange wire is HOT all the time..
PIN D1 Brown wire is HOT IN RUN ....
pin C12 black is ground..


ON the dash mounted AC control head...

PIN 1 is brown .. HOT IN RUN..  from the same AC fuse as the brown wire above.

PIN 2 & pin 10  black.. are ground to splice S203 then to ground connection G201 like the black circuit above..

PIN 3 has 5 VOLTS reference voltage from the heater and AC programmer pin ***

PIN 4 and PIN 5 are data from the programmer.. please DON'T probe them except with a logic probe...

perhaps this will help...  

Post Reply
coldbeaver
I love my Chevy Chevette!
Posts: 2
Joined: 11/11
Posted: 11/01/11 11:26 AM

i have a 92 and the a/c clutch will not engage.  the low pressure cycling switch has 5 volts on blue wire and battery voltage on green/yel.  coming out of the pcm there is 9.82 volts coming out of pin b5.  this wire goes to the a/c clutch relay and is suppose to be a ground for the relay from what i can tell.  jumped the green/wht wire to ground and a/c works as advertised, except will not cycle.  does this mean the pcm is fried.  high pressure switch has ground, 5 volt reference on gry wire.  

also, wipers will work, but will not cut off when switched to off position.  they will cut of and return to park when vehicle is shut down.  

Post Reply
waynep7122
I mow my lawn and find Chevys
Posts: 1114
Joined: 08/09
Posted: 11/01/11 07:06 PM

lets start with the wipers....

here is the diagram...

0900C1528008fdaf


i would like to know.. if the washer pump is spinning all the time when the key is on???

put some water in the windshield washer tank... see what happens..

if so... i would bet that the MIST button or the washer button has broken and is stuck in the ON position... this would keep the wipers working as you describe.. i just went through this on a 2003 dodge...  i took a short cut and just depinned the connector cavity where it plugs into the back of the switch..

on this model .. you can actually get to the wiring connections without tearing into the column..

you are going to have to figure out what gets what....  

Post Reply
waynep7122
I mow my lawn and find Chevys
Posts: 1114
Joined: 08/09
Posted: 11/01/11 07:31 PM

as far as the compressor control....

i only got one page of many on that.. and it does not cover the compressor control...  my friends shop about 10 miles from here so i don't get over there through LA traffic often..

you are going to be better off getting the diagrams and test pages from either alldatadiy.com    or eautorepair.net     both have the same factory data...

if i had it in front of me.. i might be able to help..


i did find this for a 97 C5 model...

0996B43f8024b399

i don't know how close it is to what you have..  

Post Reply
Joe Smith35
I love my Chevy Chevette!
Posts: 1
Joined: 04/14
Posted: 04/29/14 09:26 PM

hey i am having the same problem with my vet went AND GOT I TOUT OF WINTER STORAGE AND SAME THING NO HEAT CONTOLS ITS ALL LIGHT UP BUT NOTHING WORKS ALSO THE RADIO IS ON BUT NO SOUND?
AND THE CRSTY FUSE KEEPS BLOWING
SO DID YOU EVER FIGURE OUT HOW TO FIX YRS?? Wink  

Post Reply
wayne712222
My first time was in a Chevy
Posts: 143
Joined: 10/13
Posted: 04/30/14 12:03 AM

joe..  post a year. and i might be able to help..

there are a LOT of circuits..

have you checked for rodent damage??? small animals eat the insulation off the wiring when they get hungry..

and.. DO you have the C60 manual HVAC controls. or the C68 automatic climate control??? totally different systems in the same location  

Post Reply
wayne712222
My first time was in a Chevy
Posts: 143
Joined: 10/13
Posted: 04/30/14 12:05 AM

joe..  post a year. and i might be able to help..

there are a LOT of circuits..

have you checked for rodent damage??? small animals eat the insulation off the wiring when they get hungry..

and.. DO you have the C60 manual HVAC controls. or the C68 automatic climate control??? totally different systems in the same location  

Post Reply
TO TOP