Ad Radar
Item Posts    Sort Order

not all rockers are getting oil

 
ricky.wright10
I love my Chevy Chevette!
Posts: 2
Joined: 04/13
Posted: 04/28/13 02:55 AM

i have a strong 350 in wich i bent a posi lock, after replacing the set and resetting the valve lash and running the engine to operating temp i've noticed not all rockers are getting oil. i have removed and blown out all defective pushrods but the problem remains. it is 4 on each side randomly spread  

Post Reply
Dave632
I mow my lawn and find Chevys
Posts: 2253
Joined: 07/08
Posted: 04/28/13 03:24 PM

Do you have oil restrictors in the block?
They will cause a limited amount of oil to go to the valve train.  
[[SUPPORT AMERICAN CARS, STOMP A RICE CAR TODAY.]]

Post Reply
ricky.wright10
I love my Chevy Chevette!
Posts: 2
Joined: 04/13
Posted: 04/30/13 01:07 AM

not that im aware of, at ran it hard at a track day when the posi gave way and it dident make any unusual noise before hand. im thinking possibly the lifters??? the engine has not done many kms but they have been hard ones. its also been resting in the shed for years while ive been travelling  

Post Reply
redneckjoe69
I mow my lawn and find Chevys
Posts: 2337
Joined: 03/10
Posted: 04/30/13 03:40 AM

if hyd lifters, try re-setting the valve-lash on all the cylinders again, while the engine is running.  

Post Reply
WScott
V-6 Camaros rule!
Posts: 40
Joined: 03/12
Posted: 04/30/13 04:41 AM

out of curiosity how is your oil pressure at idle when hot, are you getting
oil through the rockers when you increase rpm, also if you are running poly locks on
heads with short rocker studs with roller rockers you do not have enough threads
for the nuts and studs to have sufficient strength under severe punishment  

Post Reply
TO TOP