Item Posts    Sort Order

Need help with Edelbrock carb!!! PLEASE!!!

 
Stark
I love my Chevy Chevette!
Posts: 4
Joined: 07/09
Posted: 07/23/09 07:33 PM

I have a 1986 Chevy 350 with an Edelbrock carb 600cfm 1406 Performer Series and it just one day decided to die. I took it all apart and cleaned EVERYTHING, bought new gaskets, put it all together and it runs...but horribly. Everything is hooked up or plugged. This has the electric choke and I am thinking this is the problem since the engine idles around 300 rpms and giving it any gas will make it either backfire out the carb and die or it will stumble and the rpms will drop to zero. There is no way there is an air leak like the manual suggests, the floats are the right height but I'm not sure about the mixture screws, can't tell how many turns out is too rich, right now they are set at 2 1/2 turns out from seated. I've emailed Edelbrock themselves but refuse to respond and I'm getting sick of this thing not running like a champ. Every and any insight is extremely appreciated Laugh  

Post Reply
waynep712
I have an SS396 tatoo
Posts: 264
Joined: 01/08
Posted: 07/23/09 09:47 PM

ok...   did you download the edelbrock carb manual from their web site...

did you clean all the little air bleeds in the removable boosters.?????   spray them clean...  verify by shooting spray through them...  did the boosters go back in the same spots???   how about the gaskets under them..????

the choke has to be open... for the idle speed to be set...  if the choke blade is not straight up and down.. its not all the way open...

what happens when you move the accelerator linkage.. can you look straight down the top of the carb... with the choke open..  and see if the pump shot is instant from both shooter nozzles...  if its not.. post it...

if this is one of the first carbs you have overhauled.. that might be the reason for the lack of response..

get it on this page...

http://www.edelbrock.com/automotive_new/misc/tech_center/install/1000.shtml

the installation instructions and the manual...    read them... both.. might take an hour...

did you adjust the idle speed screw?????    bring up the idle speed...  

its easier to reduce idle speed .. than turning it up when the engine keeps stalling..

and...  the most important thing...      has it run since it died????     perhaps it's not the carb????   the fuel pump, the intake gasket???  power brake booster.. ignition system??? timing chain???  

Post Reply
Stark
I love my Chevy Chevette!
Posts: 4
Joined: 07/09
Posted: 07/24/09 01:06 PM

I have read the whole manual (downloaded) and I cleaned EVERYTHING with air and cleaner and checked all the gaskets and replaced two. I have set the idle speed but still backfires but I will re-check the choke and somebody suggeted it may be the timing so I will re-check that as well. I drove this car for about a year and it one day didnt start but it starts now but undriveable. I will also check the fuel pump. Thank you for the post. Laugh  

Post Reply
Stark
I love my Chevy Chevette!
Posts: 4
Joined: 07/09
Posted: 07/24/09 03:39 PM

YYYEEESSS!!! I fixed it! It was the timing all along. It now runs and drives better than when I got it! Thank you!  

Post Reply
TO TOP