Item Posts    Sort Order

Turn Signal Problems

 
YoungMachanic8
V-6 Camaros rule!
Posts: 39
Joined: 11/08
Posted: 11/27/08 04:04 PM

I have a 1963 chevy impala hardtop. My problem is my brake light won't stop flashing whenever I use my turn signal. I replaced the turn signal switch, neutral/safety switch, and the 12 volt but I still haven't fixed the problem. People tell me it could be a loose ground but I didn't have this problem until I replaced my turn signal switch(which was bad). What could it be?  

Post Reply
canted
I have an SS396 tatoo
Posts: 499
Joined: 02/08
Posted: 11/28/08 06:31 PM

Brake light and turn signal use the same bulb. Not sure what you mean.  
Jim
70 El Camino
461 solid, m20,
pics in readers rides
thanks for over 3000 views

Post Reply
big-gm-tech
V-6 Camaros rule!
Posts: 84
Joined: 07/08
Posted: 11/29/08 12:01 PM

Hey Guy. I'm going to ask a stupid question has somebody added  a 3rd brake light, also you say the light will not quit flashing you do mean on the rear of the car and not the dash. something else to check if you hit you brakes does you any lights in front of the car light up.  When you installed the turn signal switch was the white from the switch going to the brake switch and when you done this did you replace all or any of the bulbs to check if they worked. Does the 63 have the 4 tail lights in the trunk lid if so, is one on each side a brake light and one a turn light, or are they both stop and turn. let me know on these questions and we will do the best to help you get your problem fixed.

thanks
Lee  

Post Reply
YoungMachanic8
V-6 Camaros rule!
Posts: 39
Joined: 11/08
Posted: 12/01/08 08:16 AM

When I use my turn signal all lights flash in the rear.  

Post Reply
YoungMachanic8
V-6 Camaros rule!
Posts: 39
Joined: 11/08
Posted: 12/01/08 08:55 AM

Yes they won’t stop flashing in the rear when I use my turn signal. My 63 has the 6 tail lights total, 4 in the truck lid and one on each side. When I hit brakes no other lights in the front light up and the white wire does run to the brake switch from the turn signal.
All the bulbs work I doubled checked and I haven’t replaced any of them. But there was a extra brake light routed in but I removed it.  The lights will not quit flashing on the rear of the car ,until I pull on the light switch on for the headlights and the turn signal doesn’t work at all, all you see is brake lights. I don’t know I think both were stop and turn. I hope I have cleared up some of your questions and thank you for helping me. I appreciate it.  

Post Reply
YoungMachanic8
V-6 Camaros rule!
Posts: 39
Joined: 11/08
Posted: 12/04/08 09:31 PM

I have finally solved the problem and it was a simple one!  One of my taillight sockets had a short, after I repaced it everything went back to normal. I WOULD LIKE TO THANK EVERYONE WHO HELP ME WITH MY PROBLEM. Thank you for taking time out of your day to help me Big-GM-TECH.I guess this is something you face being a young machanic. THANKS  

Post Reply
big-gm-tech
V-6 Camaros rule!
Posts: 84
Joined: 07/08
Posted: 12/04/08 09:45 PM

I rely like to be praised some time, but for you to think I'm a young tech you just made my week. I don't consider 45 to young but anyway thanks. As far as the car I knew it had to be something simple just finding what it was. Cool

you have a merry Christmas and a happy new year  

thanks
Lee  

Post Reply
ramiro81
I love my Chevy Chevette!
Posts: 4
Joined: 12/08
Posted: 12/05/08 07:04 PM

LOOK man replace the whole turnsignal assembly .they sell the wiring to replace it.Also the fuse box gets old the wires get hot and stick together and short out fuses or lights wont work properly.BUt most important the ground has alot to do also check them all.  

Post Reply
YoungMachanic8
V-6 Camaros rule!
Posts: 39
Joined: 11/08
Posted: 12/05/08 08:52 PM

Thank you BIG-GM-TECH you helped a young machanic learn a valuable lesson. Every isn't hard unless you make it that why!  

Post Reply
kawasa
I love my Chevy Chevette!
Posts: 11
Joined: 10/10
Posted: 10/14/10 01:32 AM

Good info about turn signal switch, let me bookmark this page. I'm an amateur mechanic as well so thumbs up.  

Post Reply
Ron1189
I love my Chevy Chevette!
Posts: 1
Joined: 09/12
Posted: 09/02/12 09:34 AM

I have a 1963 Chev belair. When I put on the left blinker it works until I apply the brakes, then just stays lit up. I've replaced front and rear wire harnesses for the lights, I've changed the bulbs but can't figure out what is going on. Any help would be appreciated.  

Post Reply
waynep71222
I have an SS396 tatoo
Posts: 448
Joined: 03/12
Posted: 09/02/12 10:55 AM

Icon Quote:
I have a 1963 Chev belair. When I put on the left blinker it works until I apply the brakes, then just stays lit up. I've replaced front and rear wire harnesses for the lights, I've changed the bulbs but can't figure out what is going on. Any help would be appreciated.

turn and tail light bulbs have not just two connections...  they have a hidden 3rd connection.. the ground...



tail light circuit

brake/turn light circuit

Ground to the brass shell of the bulb.. you will notice a small solder joint right at the base of the bulb.. where the wire from both the filaments are connected to the shell .


electrons flow from Negative to positive....

why it kinda works is its dragging electrons through the tail light filament on the other side....

check your ground wire connection.. if your sockets are only grounded to the hold in clips...

you can add an additional ground connection for each bulb..   i strip back some 18 gauge wire... make a loop right at the base of the bulb.. i do this with bulb out... twist it tight. i tend to touch a tiny solder joint on it...   stick the end of the wire through the gap in the socket.. install the bulb...    stick the socket into the tail light housing...   put a ring terminal on the end of the new bulb ground wire... and find a good place to ground it... this will usually fix your ground issues when they only effect one side...

if both sides are acting really strange...   you can do the loop.. but i would want to check the ground connections up front...

should be 3 ground connections

battery neg to the engine block..
battery neg to the body
engine block to the body.. usually at the firewall..
without all these you will have problems all over the car.. as you will not have enough electrons to operate all the circuits ..  

Post Reply
TO TOP