Item Posts    Sort Order

Help chevy 350 acts like it wants to stalls out when I get on it.

 
ChevySilverado4X4
I love my Chevy Chevette!
Posts: 2
Joined: 10/08
Posted: 10/06/08 12:00 AM

My 94 Chevy Silverado throttle body 350 runs good, but when I get on it. It acts like it is going to die. If I hold my foot on the gas it will spits and sputter then takes off with a lot of power. The rps will drop almost to nothing then spike. If I take off slow it will runs fine. Why is it wanting to die when i give it gas?  Confused I have replaced fuel lines, tank, pump, sending unit, plugs and wires, distributor cap,coil, and throttle body sensor. Can some one help I'm not sure where to go next. I thought about going to a junk yard and getting sensors and anything else I can get my hands on. And replace one thing at a time to see if I can fix the problem. I'm willing to take any and all ideas.  

Post Reply
ousoonerfan2006
I love my Chevy Chevette!
Posts: 6
Joined: 11/08
Posted: 11/03/08 04:47 AM

I have a 94 gmc 4x4 and I also have the same problem, I have changed all of the same components plus a computer, distributor,injectors map sensor,and knock sensor. I'm still stumped.  Confused  

Post Reply
bbfx88
V-6 Camaros rule!
Posts: 40
Joined: 12/07
Posted: 11/03/08 04:21 PM

When  and under what conditions did this problem occur? how much exhaust is coming out of the tail pipe at WOT?   Bad/restricted cat?  

Post Reply
ousoonerfan2006
I love my Chevy Chevette!
Posts: 6
Joined: 11/08
Posted: 11/05/08 01:12 AM

Mine has been this way since I bought it, I have swapped motors(thought it might have been a head gasket) and just about everything else since then with the same results. I have no cats, I thought of that and replaced the factory cat with a glass pack and still retained the factory muffler. when it starts stalling I can hammer it and it chuggs for a split second then it comes alive again.  

Post Reply
ChevySilverado4X4
I love my Chevy Chevette!
Posts: 2
Joined: 10/08
Posted: 11/09/08 12:38 AM

I also have swapped motors in my truck and I was still getting the same result. I didn't think about the cat. I will try messing with that. I did replace a couple of vacuum lines and it did help. But know it is starting to act up again. A couple of nights ago I hammered it and the truck shut off on me. My head lights and dash lights were still on, but the battery light also came on. I slipped the truck into neutral and it started right back up like there was nothing wrong spun the tires and took off. It has also almost died on me as I was turn at a corner. I slowed down made the corner gave it a little gas and nothing. RPMs dropped to nothing for a few seconds and then it is like everything catches up and the truck has more than enough power to set you back in the seat. Could a bad ground wire cause any of these problems? The conditions don't seem to matter. Warm or cold weather the same thing happens. Let the truck sit and warm up or take off cold the same thing happens.  

Post Reply
fastermatt
I love my Chevy Chevette!
Posts: 1
Joined: 12/08
Posted: 12/06/08 12:22 PM

Has anyone figured out the reason for the cutting out yet. The reason I ask this is because my truck wont run and it started the exact same way. It would drive fine I could accelerate fine while driving but from a standstill it would almost stall.

Now when I start the truck it runs for 2 seconds then dies.

If someone could help me I would be forever indebted to them.  

Post Reply
beaker58
I love my Chevy Chevette!
Posts: 6
Joined: 07/08
Posted: 12/06/08 02:51 PM

I'm not sure if this is going to help,I had a friend that had the same problem.He changed the tbi,he changed,,,well everything,,and then I asked????have you checked the crank posistion sensor,,,and his reply,,,ah,no,,,and I said,,try that,,,and he has been driving the truck ever sense without a problem.Now,I'm not telling you to run out and do this,,,but it couldn't hurt to take a look at it,,,they do get beat up and dirty,,,and they will fool you into thinking you have a fuel problem.I've had a lot of GM's come through the shop I work in and I too have thought it was the fuel pump,,,and it turned out to be that sensor.I hope this helps and fixes your problem.  

Post Reply
ousoonerfan2006
I love my Chevy Chevette!
Posts: 6
Joined: 11/08
Posted: 12/10/08 04:08 AM

mine has no crank position sensor.  

Post Reply
zherm77
I love my Chevy Chevette!
Posts: 11
Joined: 02/08
Posted: 12/30/08 11:52 PM

sounds to me like its getting too much gas or air at one time making the mixture imbalanced and it'll run fine once either the gas or the air can catch up to the one that is out of balance  

Post Reply
wilteror
I love my Chevy Chevette!
Posts: 1
Joined: 10/11
Posted: 10/18/11 05:42 PM

i have a 85 k10 4x4 Cool  that is having close to the same problems. Frown  it will run good at an idle but as soon as i get goin it will sputters out and then dies. Mad then it mite run for around twn and be fine.... Laugh  but then i  hit the highway it sputters..cuts out and give up Mad  a few and then it starts up and is fine it seems and then it all the same over and over!!! Mad  i must figure this out fast  Frown  

Post Reply
Pontiacman2
Moderator
Posts: 8956
Joined: 09/08
Posted: 10/18/11 05:47 PM

Have you replaced the fuel filter?
Have you checked for splits or pin holes in the fuel lines?  
Pontiacman2
Pontiacman2

Professional Hi-performance engine builder

Post Reply
TO TOP